summaryrefslogtreecommitdiffstats
path: root/c/src/exec/posix/inline/rtems/posix/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2001-02-05 18:31:28 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2001-02-05 18:31:28 +0000
commit890f07cb8310463a56fd1a642d378ae98ea7913f (patch)
treec59416eebf7f338ffa6a270d16df6f884811cac5 /c/src/exec/posix/inline/rtems/posix/Makefile.am
parent2001-02-03 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-890f07cb8310463a56fd1a642d378ae98ea7913f.tar.bz2
2001-02-03 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* include/Makefile.am, include/rtems/posix/Makefile.am, include/sys/Makefile.am, inline/rtems/posix/Makefile.am, macros/rtems/posix/Makefile.am: Apply include_*HEADERS instead of H_FILES.
Diffstat (limited to 'c/src/exec/posix/inline/rtems/posix/Makefile.am')
-rw-r--r--c/src/exec/posix/inline/rtems/posix/Makefile.am12
1 files changed, 7 insertions, 5 deletions
diff --git a/c/src/exec/posix/inline/rtems/posix/Makefile.am b/c/src/exec/posix/inline/rtems/posix/Makefile.am
index a479cf611b..3e6ba01d54 100644
--- a/c/src/exec/posix/inline/rtems/posix/Makefile.am
+++ b/c/src/exec/posix/inline/rtems/posix/Makefile.am
@@ -4,15 +4,17 @@
AUTOMAKE_OPTIONS = foreign 1.4
-#I_FILES= intr.inl
+include_rtems_posixdir = $(includedir)/rtems/posix
+
+noinst_HEADERS = intr.inl
I_FILES = cond.inl key.inl mqueue.inl mutex.inl pthread.inl priority.inl \
semaphore.inl timer.inl
-noinst_HEADERS = $(I_FILES)
-
if INLINE
+include_rtems_posix_HEADERS = $(I_FILES)
+
PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/posix \
- $(I_FILES:%=$(PROJECT_INCLUDE)/rtems/posix/%)
+ $(include_rtems_posix_HEADERS:%=$(PROJECT_INCLUDE)/rtems/posix/%)
$(PROJECT_INCLUDE)/rtems/posix:
@$(mkinstalldirs) $@
@@ -22,6 +24,6 @@ endif
all-local: $(PREINSTALL_FILES)
-EXTRA_DIST = intr.inl
+EXTRA_DIST = intr.inl $(I_FILES)
include $(top_srcdir)/../../../../automake/local.am