summaryrefslogtreecommitdiffstats
path: root/c/src/exec/posix/include/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>1999-09-07 13:45:03 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>1999-09-07 13:45:03 +0000
commite1d8abbe2800defb344dcce54c401733edd1d37a (patch)
tree56e416222d2ed47222be37f868a06c93656edc72 /c/src/exec/posix/include/Makefile.am
parentRemoved by patch rtems-rc-19990820-6.diff.gz from (diff)
downloadrtems-e1d8abbe2800defb344dcce54c401733edd1d37a.tar.bz2
Applied patch rtems-rc-19990820-6.diff.gz from
Ralf Corsepius <corsepiu@faw.uni-ulm.de> which converted many Makefile.in's to Makefile.am's. This added a lot of files.
Diffstat (limited to 'c/src/exec/posix/include/Makefile.am')
-rw-r--r--c/src/exec/posix/include/Makefile.am31
1 files changed, 31 insertions, 0 deletions
diff --git a/c/src/exec/posix/include/Makefile.am b/c/src/exec/posix/include/Makefile.am
new file mode 100644
index 0000000000..e56df2781a
--- /dev/null
+++ b/c/src/exec/posix/include/Makefile.am
@@ -0,0 +1,31 @@
+#
+# $Id$
+#
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+# RTEMS unistd.h needs to be checked against newlib's and removed
+#noinst_HEADERS= devctl.h intr.h
+H_PIECES = pthread.h sched.h aio.h mqueue.h semaphore.h
+
+noinst_HEADERS = $(H_PIECES)
+
+TMPINSTALL_FILES = \
+$(PROJECT_INCLUDE) \
+$(noinst_HEADERS:%=$(PROJECT_INCLUDE)/%)
+
+$(PROJECT_INCLUDE):
+ @$(mkinstalldirs) $@
+$(PROJECT_INCLUDE)/%.h: %.h
+ $(INSTALL_DATA) $< $@
+
+all-am: $(TMPINSTALL_FILES)
+debug-am: $(TMPINSTALL_FILES)
+profile-am: $(TMPINSTALL_FILES)
+
+SUBDIRS = rtems sys
+
+EXTRA_DIST = intr.h devctl.h
+
+include $(top_srcdir)/../../../../automake/subdirs.am
+include $(top_srcdir)/../../../../automake/local.am