summaryrefslogtreecommitdiffstats
path: root/c/src/exec/posix/include/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2001-10-16 13:30:22 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2001-10-16 13:30:22 +0000
commit5be35eecb438fb7c18d979215cce927a2e863996 (patch)
treeeeb4bef07ac28ce7cfd74865ced48ac358dce01c /c/src/exec/posix/include/Makefile.am
parent2001-10-16 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-5be35eecb438fb7c18d979215cce927a2e863996.tar.bz2
2001-10-16 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* include/sys/Makefile.am: Remove. * include/rtems/Makefile.am: Remove. * include/rtems/posix/Makefile.am: Remove. * include/Makefile.am: Handle subdirs. * inline/rtems/Makefile.am: Remove. * inline/rtems/posix/Makefile.am: Remove. * inline/Makefile.am: Handle subdirs. * macros/rtems/Makefile.am: Remove. * macros/rtems/posix/Makefile.am: Remove. * macros/Makefile.am: Handle subdirs. * configure.ac: Reflect changes above.
Diffstat (limited to 'c/src/exec/posix/include/Makefile.am')
-rw-r--r--c/src/exec/posix/include/Makefile.am55
1 files changed, 47 insertions, 8 deletions
diff --git a/c/src/exec/posix/include/Makefile.am b/c/src/exec/posix/include/Makefile.am
index f01d9416cc..0b9e026a7a 100644
--- a/c/src/exec/posix/include/Makefile.am
+++ b/c/src/exec/posix/include/Makefile.am
@@ -2,8 +2,19 @@
## $Id$
##
-AUTOMAKE_OPTIONS = foreign 1.4
+AUTOMAKE_OPTIONS = foreign 1.5
+$(PROJECT_INCLUDE):
+ @$(mkinstalldirs) $@
+$(PROJECT_INCLUDE)/sys:
+ @$(mkinstalldirs) $@
+$(PROJECT_INCLUDE)/rtems/posix:
+ @$(mkinstalldirs) $@
+
+$(PROJECT_INCLUDE)/%.h: %.h
+ $(INSTALL_DATA) $< $@
+
+# include
noinst_HEADERS = devctl.h intr.h
include_HEADERS = sched.h aio.h mqueue.h semaphore.h
@@ -11,16 +22,44 @@ include_HEADERS = sched.h aio.h mqueue.h semaphore.h
PREINSTALL_FILES = $(PROJECT_INCLUDE) \
$(include_HEADERS:%=$(PROJECT_INCLUDE)/%)
-$(PROJECT_INCLUDE):
- @$(mkinstalldirs) $@
-$(PROJECT_INCLUDE)/%.h: %.h
- $(INSTALL_DATA) $< $@
+# sys
-all-local: $(PREINSTALL_FILES)
+include_sysdir = $(includedir)/sys
+
+include_sys_HEADERS = sys/utsname.h
+
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/sys \
+ $(include_sys_HEADERS:%=$(PROJECT_INCLUDE)/%)
+
+# rtems/posix
+
+include_rtems_posixdir = $(includedir)/rtems/posix
+
+MP_H_FILES = rtems/posix/condmp.h rtems/posix/mqueuemp.h rtems/posix/mutexmp.h \
+ rtems/posix/pthreadmp.h rtems/posix/semaphoremp.h
-SUBDIRS = rtems sys
+STD_H_FILES = rtems/posix/cancel.h rtems/posix/cond.h rtems/posix/config.h \
+ rtems/posix/key.h rtems/posix/mqueue.h rtems/posix/mutex.h \
+ rtems/posix/posixapi.h rtems/posix/priority.h rtems/posix/psignal.h \
+ rtems/posix/pthread.h rtems/posix/ptimer.h rtems/posix/semaphore.h \
+ rtems/posix/threadsup.h rtems/posix/time.h rtems/posix/timer.h \
+ $(MP_H_FILES)
+
+noinst_HEADERS += rtems/posix/intr.h rtems/posix/threadsup.h
+
+if HAS_MP
+include_rtems_posix_HEADERS = $(STD_H_FILES) $(MP_H_FILES)
+else
+include_rtems_posix_HEADERS = $(STD_H_FILES)
+endif
+
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/posix \
+ $(include_rtems_posix_HEADERS:%=$(PROJECT_INCLUDE)/%)
+
+## General
+
+all-local: $(PREINSTALL_FILES)
EXTRA_DIST = $(noinst_HEADERS)
-include $(top_srcdir)/../../../../automake/subdirs.am
include $(top_srcdir)/../../../../automake/local.am