summaryrefslogtreecommitdiffstats
path: root/c/src/exec/libblock/include/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2002-02-28 20:39:54 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2002-02-28 20:39:54 +0000
commite51bd967cda1989d606b5b6178ed6d2c8d151707 (patch)
tree09f95b89a25c51e6e9f711afca3878f0e0bab251 /c/src/exec/libblock/include/Makefile.am
parent2002-02-27 Ilya Alexeev <ilya@continuum.ru> (diff)
downloadrtems-e51bd967cda1989d606b5b6178ed6d2c8d151707.tar.bz2
2002-02-28 Joel Sherrill <joel@OARcorp.com>
* Submitted by Victor V. Vengerov <vvv@oktet.ru> and merged into the RTEMS source. * ChangeLog, Makefile.am, README, configure.ac, include/Makefile.am, include/rtems/bdbuf.h, include/rtems/blkdev.h, include/rtems/diskdevs.h, include/rtems/ramdisk.h, include/rtems/.cvsignore, include/.cvsignore, src/Makefile.am, src/bdbuf.c, src/blkdev.c, src/diskdevs.c, src/ramdisk.c, src/.cvsignore, .cvsignore: New files.
Diffstat (limited to 'c/src/exec/libblock/include/Makefile.am')
-rw-r--r--c/src/exec/libblock/include/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/c/src/exec/libblock/include/Makefile.am b/c/src/exec/libblock/include/Makefile.am
new file mode 100644
index 0000000000..298ae2974d
--- /dev/null
+++ b/c/src/exec/libblock/include/Makefile.am
@@ -0,0 +1,23 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.5
+
+include_rtemsdir = $(includedir)/rtems
+
+$(PROJECT_INCLUDE)/%.h: %.h
+ $(INSTALL_DATA) $< $@
+
+$(PROJECT_INCLUDE)/rtems:
+ @$(mkinstalldirs) $@
+
+include_rtems_HEADERS = \
+ rtems/bdbuf.h rtems/blkdev.h rtems/diskdevs.h rtems/ramdisk.h
+
+PREINSTALL_FILES = $(PROJECT_INCLUDE)/rtems \
+ $(include_rtems_HEADERS:%=$(PROJECT_INCLUDE)/%)
+
+all-local: $(PREINSTALL_FILES)
+
+include $(top_srcdir)/../../../automake/local.am