summaryrefslogtreecommitdiffstats
path: root/c/src/configure.in
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-10-25 17:12:07 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-10-25 17:12:07 +0000
commite590416ad91d64618749602cde0884d2f22a6bea (patch)
tree5c56e8d9c7e3a2e886afb79a610fba8ab22aa487 /c/src/configure.in
parent2000-10-25 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-e590416ad91d64618749602cde0884d2f22a6bea.tar.bz2
2000-10-25 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* configure.in, Makefile.am: add exec to the GNU canonicalized subdirectories.
Diffstat (limited to '')
-rw-r--r--c/src/configure.in8
1 files changed, 6 insertions, 2 deletions
diff --git a/c/src/configure.in b/c/src/configure.in
index 44da082d7f..1de90c394a 100644
--- a/c/src/configure.in
+++ b/c/src/configure.in
@@ -25,11 +25,11 @@ RTEMS_CHECK_CUSTOM_BSP(RTEMS_BSP)
RTEMS_CHECK_NETWORKING(RTEMS_BSP)
## Note: the order of the directories below is essential
-cfg_subdirs="make"
+cfg_subdirs1="make"
## Exclude exec from building if multilibs are enabled
if test x"$multilib" = x"no"; then
-cfg_subdirs="$cfg_subdirs exec"
+hst_subdirs1="$hst_subdirs1 exec"
fi
cfg_subdirs="$cfg_subdirs lib"
cfg_subdirs="$cfg_subdirs lib/libcpu lib/libbsp"
@@ -58,9 +58,13 @@ if test "$RTEMS_HAS_CPLUSPLUS" = "yes"; then
hst_subdirs="$hst_subdirs librtems++";
fi
+RTEMS_CONFIG_HOST_SUBDIRS($hst_subdirs1)
+AC_SUBST(hst_subdirs1)
RTEMS_CONFIG_HOST_SUBDIRS($hst_subdirs)
AC_SUBST(hst_subdirs)
+AC_CONFIG_SUBDIRS($cfg_subdirs1)
+AC_SUBST(cfg_subdirs1)
AC_CONFIG_SUBDIRS($cfg_subdirs)
AC_SUBST(cfg_subdirs)