summaryrefslogtreecommitdiffstats
path: root/c/src/configure.in
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-10-24 22:06:58 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-10-24 22:06:58 +0000
commit4a2faa7c451e22fa326f3debe4441223fe911005 (patch)
treed738618d90cc11631ffedb6d3c6dee3d60f98a7d /c/src/configure.in
parent2000-10-24 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-4a2faa7c451e22fa326f3debe4441223fe911005.tar.bz2
2000-10-24 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am, acinclude.m4, configure.in: Introduce GNU canonicalization to libfs/. The approach is currently a bit of a hack as GNU canonicalization does not support the per-BSP build some of the other directories require. As more of the tree is converted, this will become less of an issue.
Diffstat (limited to '')
-rw-r--r--c/src/configure.in21
1 files changed, 16 insertions, 5 deletions
diff --git a/c/src/configure.in b/c/src/configure.in
index 25490d651a..12448f1a79 100644
--- a/c/src/configure.in
+++ b/c/src/configure.in
@@ -26,38 +26,47 @@ RTEMS_CHECK_NETWORKING(RTEMS_BSP)
## Note: the order of the directories below is essential
cfg_subdirs="make"
+
## Exclude exec from building if multilibs are enabled
if test x"$multilib" = x"no"; then
cfg_subdirs="$cfg_subdirs exec"
fi
cfg_subdirs="$cfg_subdirs lib"
cfg_subdirs="$cfg_subdirs lib/libcpu lib/libbsp"
-cfg_subdirs="$cfg_subdirs libfs libmisc"
+hst_subdirs="libfs"
+cfg_subdirs2="libmisc"
if test "$RTEMS_CPU" != "unix"; then
## HACK: Suppress libchip for unix
-cfg_subdirs="$cfg_subdirs libchip"
+cfg_subdirs2="$cfg_subdirs2 libchip"
fi
if test "$HAS_NETWORKING" = "yes"; then
- cfg_subdirs="$cfg_subdirs libnetworking librpc"
+ cfg_subdirs2="$cfg_subdirs2 libnetworking librpc"
if test "$RTEMS_HAS_RDBG" = "yes"; then
RTEMS_CHECK_RDBG(RTEMS_BSP)
fi
fi
if test "$HAS_RDBG" = "yes"; then
- cfg_subdirs="$cfg_subdirs librdbg"
+ cfg_subdirs2="$cfg_subdirs2 librdbg"
fi
AM_CONDITIONAL(HAS_NETWORKING, test "$HAS_NETWORKING" = "yes" )
AM_CONDITIONAL(HAS_RDBG, test "$HAS_RDBG" = "yes" )
if test "$RTEMS_HAS_CPLUSPLUS" = "yes"; then
- cfg_subdirs="$cfg_subdirs librtems++";
+ cfg_subdirs2="$cfg_subdirs2 librtems++";
fi
+RTEMS_CONFIG_HOST_SUBDIRS($hst_subdirs)
+AC_SUBST(hst_subdirs)
+
AC_CONFIG_SUBDIRS($cfg_subdirs)
AC_SUBST(cfg_subdirs)
+
+AC_CONFIG_SUBDIRS($cfg_subdirs2)
+AC_SUBST(cfg_subdirs2)
+
AC_CONFIG_SUBDIRS(tests)
RTEMS_PROJECT_ROOT
@@ -70,3 +79,5 @@ AC_OUTPUT(
Makefile
wrapup/Makefile
)
+
+RTEMS_OUTPUT_HOST_SUBDIRS(RTEMS_HOST_SUBDIRS)