summaryrefslogtreecommitdiffstats
path: root/c/src/configure.in
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>1999-10-11 15:34:26 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>1999-10-11 15:34:26 +0000
commit45269dc902f360953ecb9f8816beaae9daa4cec7 (patch)
tree315cdb76df196084c7ba24c0ba99ac777302e214 /c/src/configure.in
parentSwitched to the C++ front end to gcc to link. This still did not (diff)
downloadrtems-45269dc902f360953ecb9f8816beaae9daa4cec7.tar.bz2
Patch from Ralf Corsepius <corsepiu@faw.uni-ulm.de> to move librdbg
to its own top level package.
Diffstat (limited to '')
-rw-r--r--c/src/configure.in15
1 files changed, 13 insertions, 2 deletions
diff --git a/c/src/configure.in b/c/src/configure.in
index 1ca0af2fe4..be98fc35c6 100644
--- a/c/src/configure.in
+++ b/c/src/configure.in
@@ -9,6 +9,7 @@ AC_CONFIG_AUX_DIR(../..)
RTEMS_ENABLE_CXX
RTEMS_ENABLE_NETWORKING
+RTEMS_ENABLE_RDBG
RTEMS_CANONICAL_TARGET_CPU
RTEMS_CANONICAL_HOST
@@ -26,12 +27,22 @@ RTEMS_CHECK_NETWORKING(RTEMS_BSP)
AC_CONFIG_SUBDIRS(make)
AC_CONFIG_SUBDIRS(exec)
AC_CONFIG_SUBDIRS(lib)
+
if test "$HAS_NETWORKING" = "yes"; then
-cfg_subdirs="libnetworking librpc"
+ cfg_subdirs="libnetworking librpc"
+ if test "$RTEMS_HAS_RDBG" = "yes"; then
+ RTEMS_CHECK_RDBG(RTEMS_BSP)
+ fi
+fi
+
+if test "$HAS_RDBG" = "yes"; then
+ cfg_subdirs="$cfg_subdirs librdbg"
fi
+
if test "$RTEMS_HAS_CPLUSPLUS" = "yes"; then
-cfg_subdirs="$cfg_subdirs librtems++";
+ cfg_subdirs="$cfg_subdirs librtems++";
fi
+
AC_CONFIG_SUBDIRS($cfg_subdirs)
AC_CONFIG_SUBDIRS(wrapup)
AC_SUBST(cfg_subdirs)