summaryrefslogtreecommitdiffstats
path: root/c/src/configure.in
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-07-06 20:13:35 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-07-06 20:13:35 +0000
commit04e6f7bffb71106516097299e37f57bb28cf9844 (patch)
tree8442c8591d6021418c7e2a8cb681b358fdd41b3d /c/src/configure.in
parentPatch rtems-rc-20000705-2.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-04e6f7bffb71106516097299e37f57bb28cf9844.tar.bz2
Patch rtems-rc-20000705-3.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de>
that is a somewhat experimental, multilib-related patch: Changes: * Use RTEMS_ENV_RTEMSCPU instead of RTEMS_ENV_RTEMSBSP in configure.ins below exec/. At the moment, RTEMS_ENV_RTEMSCPU is more or less an optical change to emphasize that these subdirectories shall not depend on RTEMS_BSP than a real behavioral change. * Add AC_DEFINE_* to several aclocal/*.m4 macros to prepare autoheader/autoconf generated targopts.h and similiar configuration headers. * c/src/configure.in: remove exec from cfg_subdirs if multilibs are enabled (c/src is build per bsp, exec shall be build per cpu in c/ or from the toplevel in future, when multilibs are enabled.) Notes: * This patch should not have any impact on the current building scheme. * --enable-multilib still does not work. * running bootstrap from the toplevel directory is required. CVS: ---------------------------------------------------------------------- CVS: Enter Log. Lines beginning with `CVS:' are removed automatically CVS: CVS: Committing in . CVS: CVS: Modified Files: CVS: c/src/tests/libtests/termios/init.c CVS: ----------------------------------------------------------------------
Diffstat (limited to '')
-rw-r--r--c/src/configure.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/c/src/configure.in b/c/src/configure.in
index b13a6c4544..360c8b3683 100644
--- a/c/src/configure.in
+++ b/c/src/configure.in
@@ -17,6 +17,7 @@ RTEMS_CANONICAL_HOST
AM_INIT_AUTOMAKE(rtems-c-src,$RTEMS_VERSION,no)
AM_MAINTAINER_MODE
+RTEMS_ENABLE_MULTILIB
RTEMS_ENV_RTEMSBSP
RTEMS_CHECK_CPU
RTEMS_CHECK_CUSTOM_BSP(RTEMS_BSP)
@@ -25,7 +26,10 @@ RTEMS_CHECK_NETWORKING(RTEMS_BSP)
## Note: the order of the directories below is essential
cfg_subdirs="make"
+## Exclude exec from building if multilibs are enabled
+if test x"$multilib" = x"no"; then
cfg_subdirs="$cfg_subdirs exec"
+fi
cfg_subdirs="$cfg_subdirs lib"
cfg_subdirs="$cfg_subdirs libmisc"