summaryrefslogtreecommitdiffstats
path: root/c/src/configure.ac
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2009-10-17 15:15:54 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2009-10-17 15:15:54 +0000
commitd8bbc3e64d546271237e9fa9a713915e7c66b1aa (patch)
tree32ad75c7c54e54dbccd4dd08cd9d1c04360bcc2e /c/src/configure.ac
parentbinutils-2.20. (diff)
downloadrtems-d8bbc3e64d546271237e9fa9a713915e7c66b1aa.tar.bz2
2009-10-17 Ralf Corsepius <ralf.corsepius@rtems.org>
* configure.ac: Pick up make/custom/*. * aclocal/check-custom-bsp.m4: Adapt to changes to configure.ac.
Diffstat (limited to 'c/src/configure.ac')
-rw-r--r--c/src/configure.ac13
1 files changed, 6 insertions, 7 deletions
diff --git a/c/src/configure.ac b/c/src/configure.ac
index 2513d1e643..ccbe4b4dc2 100644
--- a/c/src/configure.ac
+++ b/c/src/configure.ac
@@ -42,22 +42,21 @@ EOF
# Collect and copy the BSP's make/custom/*.cfg files from the toplevel make
# directory into the build tree's <bsp>/make/custom subdirectories
CUSTOM_CFG_FILES=
-f="${RTEMS_BSP}"
+f="${RTEMS_BSP}.cfg"
while test -n "$f"; do
cfg_file=
_RTEMS_CHECK_CUSTOM_BSP([$f],cfg_file)
if test -n "${cfg_file}"; then
- cp ${cfg_file} make/custom/$f.cfg
+ cp ${cfg_file} make/custom/$f
cat << EOF >> ${DEPDIR}/cfg.P
-make/custom/$f.cfg: ${cfg_file} make/custom/default.cfg
- cp ${cfg_file} make/custom/$f.cfg
+make/custom/$f: ${cfg_file} make/custom/default.cfg
+ cp ${cfg_file} make/custom/$f
EOF
- CUSTOM_CFG_FILES="$CUSTOM_CFG_FILES make/custom/$f.cfg"
+ CUSTOM_CFG_FILES="$CUSTOM_CFG_FILES make/custom/$f"
f=`grep "^include.*make/custom" ${cfg_file} \
| sed \
-e 's%^.*custom\/%%' \
- -e 's%default\.cfg%%' \
- -e 's%\.cfg$%%'`;
+ -e 's%default\.cfg%%'`;
else break; fi;
done
#${MAKE-make} -f ${DEPDIR}/cfg.P \