summaryrefslogtreecommitdiffstats
path: root/c/src/configure.ac
diff options
context:
space:
mode:
authorChris Johns <chrisj@rtems.org>2016-08-10 13:07:29 +1000
committerChris Johns <chrisj@rtems.org>2016-08-11 17:20:10 +1000
commit9a4eca584321408ecac7b67a562d9c37be719d6a (patch)
treec8f0b5e9e4a1840ddf87d4ad6313613c1f4cf128 /c/src/configure.ac
parentposix: nanosleep: adjust elapsed time calculation (diff)
downloadrtems-9a4eca584321408ecac7b67a562d9c37be719d6a.tar.bz2
build-system: Always enable C++ if the compiler is present.
We always build a C++ compiler and building with C++ does not effect RTEMS or the runtime. This patch always enabled the support. There is no need to manually enable it any more. You can disable C++ with '--disable-cxx'. If an architecture does not have a C++ compiler support is automatically disabled.
Diffstat (limited to '')
-rw-r--r--c/src/configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/c/src/configure.ac b/c/src/configure.ac
index f0d482c4c0..6b34eb54f4 100644
--- a/c/src/configure.ac
+++ b/c/src/configure.ac
@@ -16,6 +16,7 @@ AM_MAINTAINER_MODE
RTEMS_ENABLE_MULTILIB
RTEMS_ENABLE_MULTIPROCESSING
+RTEMS_ENABLE_CXX
RTEMS_ENV_RTEMSBSP
RTEMS_CHECK_CUSTOM_BSP(RTEMS_BSP)
@@ -93,6 +94,7 @@ rtems_cv_CFLAGS_set="${CFLAGS+set}"
CFLAGS="${CFLAGS-${CPU_CFLAGS} ${CFLAGS_OPTIMIZE_V}}"
RTEMS_PROG_CC_FOR_TARGET
+RTEMS_PROG_CXX_FOR_TARGET
AM_PROG_CC_C_O
RTEMS_PROG_CCAS
RTEMS_CANONICALIZE_TOOLS