summaryrefslogtreecommitdiffstats
path: root/c/src/configure.ac
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-03-29 13:06:20 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-03-29 13:06:20 +0000
commit850c88df7f3dd29e7cdba5f1d2a60207e9980b11 (patch)
tree0ec947aa318228d50b74ab07e26ebfb5981be7e1 /c/src/configure.ac
parent2004-03-29 Ralf Corsepius <ralf_corsepius@rtems.org> (diff)
downloadrtems-850c88df7f3dd29e7cdba5f1d2a60207e9980b11.tar.bz2
2004-03-29 Ralf Corsepius <ralf_corsepius@rtems.org>
* configure.ac: Reflect changes testsuites/configure.ac and cpukit/configure.ac.
Diffstat (limited to 'c/src/configure.ac')
-rw-r--r--c/src/configure.ac23
1 files changed, 9 insertions, 14 deletions
diff --git a/c/src/configure.ac b/c/src/configure.ac
index 0ab402ec50..76fc45c490 100644
--- a/c/src/configure.ac
+++ b/c/src/configure.ac
@@ -121,7 +121,8 @@ BSP_SUBDIRS=
## Configure ${srcdir}/../../cpukit as cpukit/ if multilibs are disabled
RTEMS_BSP_CONFIG_SUBDIR(
[cpukit],[../../cpukit],
- ['--with-project-root=../../..' '--enable-rtemsbsp=$RTEMS_BSP'],
+ ['--with-project-root=${with_project_root}../$RTEMS_BSP/' \
+ '--enable-rtemsbsp=$RTEMS_BSP'],
[test x"$multilib" = x"no"])
## Note: the order of the directories below is essential
@@ -168,28 +169,22 @@ AC_ARG_ENABLE([ada],
*) AC_MSG_ERROR(bad value ${enable_ada} for --enable-ada) ;;
esac],[enable_ada=no])
-# FIXME: We should compute project_top from target-subdir
-if test -n "$with_target_subdir"; then
-project_top=../../../../
-else
-project_top=../../../
-fi
AS_IF([test x"$enable_ada" = x"yes"],[
RTEMS_BSP_CONFIG_SUBDIR(
[ada-tests],[ada-tests],
- ['--with-project-top=$project_top' \
- '--enable-rtems-root=../' \
- '--with-project-root=../../../' \
+ ['--enable-rtems-root=../' \
+ '--with-project-root=${with_project_root}../' \
+ '--with-project-top=${with_project_top}../' \
'--enable-rtemsbsp=$RTEMS_BSP' \
],
- [test x"$enable_tests" != x"no"])
+ [test x"$enable_tests" = x"yes"])
])
RTEMS_BSP_CONFIG_SUBDIR(
[testsuites],[../../testsuites],
- ['--with-project-top=$project_top' \
- '--enable-rtems-root=../' \
- '--with-project-root=../../../' \
+ ['--enable-rtems-root=../' \
+ '--with-project-root=${with_project_root}../' \
+ '--with-project-top=${with_project_top}../' \
'--enable-rtemsbsp=$RTEMS_BSP' \
],
[test x"$enable_tests" != x"no"])