summaryrefslogtreecommitdiffstats
path: root/c/src/configure.ac
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2005-01-06 10:45:41 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2005-01-06 10:45:41 +0000
commit6c2b53247747264a25aa2233706f03fb8fd3970e (patch)
treeb0aeef37da696b8ee05254430f5e79a715397fd7 /c/src/configure.ac
parent2005-01-06 Ralf Corsepius <ralf.corsepius@rtems.org> (diff)
downloadrtems-6c2b53247747264a25aa2233706f03fb8fd3970e.tar.bz2
2005-01-06 Ralf Corsepius <ralf.corsepius@rtems.org>
* configure.ac: Pass CFLAGS to testsuites configure. * aclocal/prog-cxx.m4: Don't invoke _RTEMS_FLAGS to set up RTEMS_CXXFLAGS. Setup CXXFLAGS from CFLAGS.
Diffstat (limited to 'c/src/configure.ac')
-rw-r--r--c/src/configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/c/src/configure.ac b/c/src/configure.ac
index 0e0561d5ce..6e969ca63a 100644
--- a/c/src/configure.ac
+++ b/c/src/configure.ac
@@ -133,7 +133,8 @@ RTEMS_BSP_CONFIG_SUBDIR(
['--with-project-root=${with_project_root}../$RTEMS_BSP/' \
'--includedir=${exec_prefix}/${RTEMS_BSP}/lib/include' \
'--libdir=${exec_prefix}/${RTEMS_BSP}/lib' \
- 'CFLAGS="${CFLAGS}"'],
+ 'CFLAGS="${CFLAGS}"' \
+ ],
[test x"$multilib" = xno])
## Note: the order of the directories below is essential
@@ -195,7 +196,8 @@ RTEMS_BSP_CONFIG_SUBDIR(
'--with-project-root=${with_project_root}../' \
'--with-project-top=${with_project_top}../' \
'--enable-rtemsbsp=$RTEMS_BSP' \
- ],
+ 'CFLAGS="${CFLAGS}"' \
+ ],
[test x"$enable_tests" != x"no"])
AC_SUBST([BSP_SUBDIRS],[$BSP_SUBDIRS])