summaryrefslogtreecommitdiffstats
path: root/c/src/configure.ac
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-12-15 07:24:00 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-12-15 07:24:00 +0000
commit41fc78d3793d7bda0d5d80cf598801641db6d270 (patch)
tree4638ed2504f565cd4b114318d72254d5a525a386 /c/src/configure.ac
parent2003-12-14 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-41fc78d3793d7bda0d5d80cf598801641db6d270.tar.bz2
2003-12-15 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* automake/compile.am: Remove LINK_LIBS (Unused). * configure.ac: Reflect changes to RTEMS_CONFIG_SUBDIR.
Diffstat (limited to 'c/src/configure.ac')
-rw-r--r--c/src/configure.ac15
1 files changed, 10 insertions, 5 deletions
diff --git a/c/src/configure.ac b/c/src/configure.ac
index 3f1c67b30c..06e3ce3449 100644
--- a/c/src/configure.ac
+++ b/c/src/configure.ac
@@ -117,8 +117,11 @@ AC_SUBST(cfg_dir)
## Configure ${srcdir}/../../cpukit as exec/ if multilibs are disabled
AS_IF([test x"$multilib" = x"no"],[
RTEMS_CHECK_MULTIPROCESSING
- RTEMS_CONFIG_SUBDIR([exec],[../../cpukit],
- ['--with-project-root=../../' '--enable-rtemsbsp=$RTEMS_BSP'
+ AC_CONFIG_COMMANDS_POST([
+ if test x"$multilib" = x"no"; then
+ RTEMS_CONFIG_SUBDIR([exec],[../../cpukit],
+ ['--with-project-root=../../' '--enable-rtemsbsp=$RTEMS_BSP'])
+ fi
])
BSP_SUBDIRS="exec"
])
@@ -175,12 +178,14 @@ AS_IF([test x"$enable_ada" = x"yes"],[
])
AS_IF([test -d ${srcdir}/../../testsuites],[
- RTEMS_CONFIG_SUBDIR([testsuites],[../../testsuites],
- ['--with-project-root=../../' '--enable-rtemsbsp=$RTEMS_BSP'
- ])
BSP_SUBDIRS="$BSP_SUBDIRS testsuites"
])
+ AC_CONFIG_COMMANDS_POST([
+ RTEMS_CONFIG_SUBDIR([testsuites],[../../testsuites],
+ ['--with-project-root=../../' '--enable-rtemsbsp=$RTEMS_BSP'])
+ ])
+
AC_SUBST([BSP_SUBDIRS],[$BSP_SUBDIRS])
AS_IF([test "$host_cpu" = "sparc"],[