summaryrefslogtreecommitdiffstats
path: root/c/src/configure.ac
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2007-08-02 15:00:07 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2007-08-02 15:00:07 +0000
commit261f99bdac9a995f8b2740b7ae52c8ad81001132 (patch)
tree2a5006b2c876e801a11527f6b20f47c312370b2f /c/src/configure.ac
parent2007-08-02 Joel Sherrill <joel.sherrill@OARcorp.com> (diff)
downloadrtems-261f99bdac9a995f8b2740b7ae52c8ad81001132.tar.bz2
2007-08-02 Joel Sherrill <joel.sherrill@OARcorp.com>
* configure.ac, wrapup/Makefile.am: Remove RDBG. * aclocal/check-rdbg.m4, aclocal/enable-rdbg.m4, librdbg/.cvsignore, librdbg/Makefile.am, librdbg/preinstall.am, librdbg/include/rdbg/rdbg.h, librdbg/include/rdbg/servrpc.h, librdbg/include/rdbg/i386/rdbg_f.h, librdbg/include/rdbg/i386/reg.h, librdbg/include/rdbg/m68k/rdbg_f.h, librdbg/include/rdbg/m68k/reg.h, librdbg/include/rdbg/powerpc/rdbg_f.h, librdbg/include/rdbg/powerpc/reg.h, librdbg/src/_servtgt.c, librdbg/src/awk.svc, librdbg/src/excep.c, librdbg/src/ptrace.c, librdbg/src/rdbg.c, librdbg/src/remdeb.x, librdbg/src/servbkpt.c, librdbg/src/servcon.c, librdbg/src/servrpc.c, librdbg/src/servtgt.c, librdbg/src/servtsp.c, librdbg/src/servutil.c, librdbg/src/i386/excep_f.c, librdbg/src/i386/rdbg_cpu_asm.S, librdbg/src/i386/rdbg_f.c, librdbg/src/i386/any/remdeb.h, librdbg/src/i386/any/remdeb_f.x, librdbg/src/i386/any/remdeb_svc.c, librdbg/src/i386/any/remdeb_xdr.c, librdbg/src/m68k/excep_f.c, librdbg/src/m68k/rdbg_cpu_asm.S, librdbg/src/m68k/rdbg_f.c, librdbg/src/m68k/any/remdeb.h, librdbg/src/m68k/any/remdeb_f.x, librdbg/src/m68k/any/remdeb_svc.c, librdbg/src/m68k/any/remdeb_xdr.c, librdbg/src/powerpc/excep_f.c, librdbg/src/powerpc/rdbg_cpu_asm.S, librdbg/src/powerpc/rdbg_f.c, librdbg/src/powerpc/new_exception_processing/remdeb.h, librdbg/src/powerpc/new_exception_processing/remdeb_f.x, librdbg/src/powerpc/new_exception_processing/remdeb_svc.c, librdbg/src/powerpc/new_exception_processing/remdeb_xdr.c: Removed.
Diffstat (limited to 'c/src/configure.ac')
-rw-r--r--c/src/configure.ac19
1 files changed, 0 insertions, 19 deletions
diff --git a/c/src/configure.ac b/c/src/configure.ac
index f754d78e15..b42b540975 100644
--- a/c/src/configure.ac
+++ b/c/src/configure.ac
@@ -9,7 +9,6 @@ RTEMS_TOP(../..)
RTEMS_ENABLE_CXX
RTEMS_ENABLE_NETWORKING
-RTEMS_ENABLE_RDBG
RTEMS_CANONICAL_TARGET_CPU
@@ -105,12 +104,6 @@ AM_PROG_CC_C_O
RTEMS_PROG_CCAS
RTEMS_CANONICALIZE_TOOLS
-AS_IF([test "$HAS_NETWORKING" = "yes"],[
- AS_IF([test "$RTEMS_HAS_RDBG" = "yes"],[
- RTEMS_CHECK_RDBG(RTEMS_BSP)
- ])
-])
-
RTEMS_CHECK_GCC_WEAK
AC_SUBST(CUSTOM_CFG_FILES)
@@ -152,7 +145,6 @@ fi
BSP_SUBDIRS="$BSP_SUBDIRS lib"
BSP_SUBDIRS="$BSP_SUBDIRS libchip"
-BSP_SUBDIRS="$BSP_SUBDIRS librdbg"
BSP_SUBDIRS="$BSP_SUBDIRS nfsclient"
AS_IF([test "$RTEMS_HAS_CPLUSPLUS" = "yes"],[
@@ -220,15 +212,6 @@ AS_IF([test "$host_cpu" = sparc],[
AM_CONDITIONAL([HAS_NETWORKING],[test "$HAS_NETWORKING" = "yes"])
-# FIXME: This is sick
-AM_CONDITIONAL([HAS_RDBG],[test "$HAS_RDBG" = "yes"])
-AM_CONDITIONAL([HAS_RDBG_i386],[test "$HAS_RDBG" = "yes" \
- && test $RTEMS_CPU = "i386"])
-AM_CONDITIONAL([HAS_RDBG_m68k],[test "$HAS_RDBG" = "yes" \
- && test $RTEMS_CPU = "m68k"])
-AM_CONDITIONAL([HAS_RDBG_powerpc],[test "$HAS_RDBG" = "yes" \
- && test $RTEMS_CPU = "powerpc"])
-
AM_CONDITIONAL(HAS_POSIX,test "$HAS_POSIX_API" = "yes")
# The posix bsp doesn't support libchip
@@ -259,8 +242,6 @@ AC_CONFIG_FILES([Makefile],
AC_CONFIG_FILES([
support/Makefile
-librdbg/Makefile
-
libchip/Makefile
optman/Makefile