summaryrefslogtreecommitdiffstats
path: root/c/src/configure.ac
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-11-22 07:28:19 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-11-22 07:28:19 +0000
commit259c5161bd83cc7eec3fdcc0f7e797c6c230c7e5 (patch)
tree506fa8a3667d68c9707edee4a54674a495457bdd /c/src/configure.ac
parent2004-11-22 Ralf Corsepius <ralf.corsepius@rtems.org> (diff)
downloadrtems-259c5161bd83cc7eec3fdcc0f7e797c6c230c7e5.tar.bz2
2004-11-22 Ralf Corsepius <ralf_corsepius@rtems.org>
* configure.ac: Misc. quoting cleanups. Enable ada-tests iff --enable-ada and --enable-tests.
Diffstat (limited to 'c/src/configure.ac')
-rw-r--r--c/src/configure.ac24
1 files changed, 11 insertions, 13 deletions
diff --git a/c/src/configure.ac b/c/src/configure.ac
index 712d8a3b98..ebaa4b1a9e 100644
--- a/c/src/configure.ac
+++ b/c/src/configure.ac
@@ -133,7 +133,7 @@ RTEMS_BSP_CONFIG_SUBDIR(
['--with-project-root=${with_project_root}../$RTEMS_BSP/' \
'--includedir=${exec_prefix}/${RTEMS_BSP}/lib/include' \
'--libdir=${exec_prefix}/${RTEMS_BSP}/lib'],
- [test x"$multilib" = x"no"])
+ [test x"$multilib" = xno])
## Note: the order of the directories below is essential
AC_CONFIG_SUBDIRS([make])
@@ -150,7 +150,7 @@ AC_SUBST(libcpu_cpu_subdir)
# Is there code where there should be for this BSP?
# The bare bsp is a special case as it is not under the RTEMS_CPU path
-if test "$RTEMS_BSP_FAMILY" = "bare" ; then
+if test "$RTEMS_BSP_FAMILY" = bare ; then
AC_CONFIG_SUBDIRS([lib/libbsp/bare])
AC_SUBST(libbsp_cpu_subdir,bare)
else
@@ -179,16 +179,14 @@ AC_ARG_ENABLE([ada],
*) AC_MSG_ERROR(bad value ${enable_ada} for --enable-ada) ;;
esac],[enable_ada=no])
-AS_IF([test x"$enable_ada" = x"yes"],[
- RTEMS_BSP_CONFIG_SUBDIR(
- [ada-tests],[ada-tests],
- ['--enable-rtems-root=../' \
- '--with-project-root=${with_project_root}../' \
- '--with-project-top=${with_project_top}../' \
- '--enable-rtemsbsp=$RTEMS_BSP' \
- ],
- [test x"$enable_tests" = x"yes"])
-])
+RTEMS_BSP_CONFIG_SUBDIR(
+ [ada-tests],[ada-tests],
+ ['--enable-rtems-root=../' \
+ '--with-project-root=${with_project_root}../' \
+ '--with-project-top=${with_project_top}../' \
+ '--enable-rtemsbsp=$RTEMS_BSP' \
+ ],
+ [test x"$enable_tests" = xyes && test x"$enable_ada" = xyes])
RTEMS_BSP_CONFIG_SUBDIR(
[testsuites],[../../testsuites],
@@ -201,7 +199,7 @@ RTEMS_BSP_CONFIG_SUBDIR(
AC_SUBST([BSP_SUBDIRS],[$BSP_SUBDIRS])
-AS_IF([test "$host_cpu" = "sparc"],[
+AS_IF([test "$host_cpu" = sparc],[
AC_DEFINE_UNQUOTED([CPU_U32_FIX],[1],
[whether to enable ipalignment work-around])
])