summaryrefslogtreecommitdiffstats
path: root/c/src/configure.ac
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2017-11-24 13:20:16 +0100
committerSebastian Huber <sebastian.huber@embedded-brains.de>2017-11-27 07:32:53 +0100
commit0d5c795afaf9485a02d7de0bb3282407e91c2a38 (patch)
treecfb45e4876976efe9d8c5d51be112ee9c6f86a1b /c/src/configure.ac
parentbsps: Remove empty tm27.h variants (diff)
downloadrtems-0d5c795afaf9485a02d7de0bb3282407e91c2a38.tar.bz2
Move Ada includes
Update #3254.
Diffstat (limited to 'c/src/configure.ac')
-rw-r--r--c/src/configure.ac13
1 files changed, 0 insertions, 13 deletions
diff --git a/c/src/configure.ac b/c/src/configure.ac
index 0ef63ce80b..b55962cb65 100644
--- a/c/src/configure.ac
+++ b/c/src/configure.ac
@@ -142,17 +142,8 @@ AC_SUBST(libbsp_cpu_subdir,$RTEMS_CPU)
BSP_SUBDIRS="$BSP_SUBDIRS lib"
BSP_SUBDIRS="$BSP_SUBDIRS libchip"
BSP_SUBDIRS="$BSP_SUBDIRS support"
-BSP_SUBDIRS="$BSP_SUBDIRS ada"
BSP_SUBDIRS="$BSP_SUBDIRS wrapup"
-AC_ARG_ENABLE([ada],
-[AS_HELP_STRING(--enable-ada,enable ada support)],
-[case "${enable_ada}" in
- yes) ;;
- no) ;;
- *) AC_MSG_ERROR(bad value ${enable_ada} for --enable-ada) ;;
-esac],[enable_ada=no])
-
# HACK ALERT!
# FIXME: Assume multilib implies in-source-tree multilibs
@@ -191,9 +182,6 @@ AS_IF([test "$host_cpu" = sparc],[
AM_CONDITIONAL([HAS_NETWORKING],[test "$HAS_NETWORKING" = "yes"])
AM_CONDITIONAL(HAS_SMP,[test "$rtems_cv_HAS_SMP" = "yes"])
-AM_CONDITIONAL(RTEMS_ADA,[test x"$enable_ada" = x"yes" \
- && test x"$rtems_cv_HAS_POSIX_API" = x"yes"])
-
RTEMS_PROJECT_ROOT
# Explicitly list all Makefiles here
@@ -208,7 +196,6 @@ libchip/Makefile
lib/Makefile
lib/libcpu/Makefile
lib/libbsp/Makefile
-ada/Makefile
wrapup/Makefile
])