summaryrefslogtreecommitdiffstats
path: root/c/src/ada/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2002-08-23 13:52:42 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2002-08-23 13:52:42 +0000
commit72deed07461bb1c6cdb03549195cf1581c4e1b2c (patch)
treec034e9fea33d3d5ad2b2df984b0194453e70147c /c/src/ada/Makefile.am
parent2002-08-22 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-72deed07461bb1c6cdb03549195cf1581c4e1b2c.tar.bz2
2001-08-23 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* configure.ac: New. * Makefile.am: New. * .cvsignore: New.
Diffstat (limited to '')
-rw-r--r--c/src/ada/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/c/src/ada/Makefile.am b/c/src/ada/Makefile.am
new file mode 100644
index 0000000000..5702b5459d
--- /dev/null
+++ b/c/src/ada/Makefile.am
@@ -0,0 +1,20 @@
+ACLOCAL_AMFLAGS = -I ../aclocal
+
+$(PROJECT_INCLUDE)/adainclude:
+ $(mkinstalldirs) $@
+$(PROJECT_INCLUDE)/adainclude/%: %
+ $(INSTALL_DATA) $< $@
+
+adaincludedir = $(includedir)/adainclude
+
+adainclude_HEADERS = rtems.adb rtems.ads
+adainclude_HEADERS += rtems-multiprocessing.adb rtems-multiprocessing.ads
+
+TMPINSTALL_FILES = \
+ $(PROJECT_INCLUDE)/adainclude \
+ $(adainclude_HEADERS:%=$(PROJECT_INCLUDE)/adainclude/%) \
+ $(nodist_adalib_HEADERS:%=$(PROJECT_INCLUDE)/adainclude/%)
+
+all-local: $(TMPINSTALL_FILES)
+
+include $(top_srcdir)/../automake/local.am