summaryrefslogtreecommitdiffstats
path: root/c/configure.ac
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2018-04-21 10:22:08 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2018-04-23 15:18:42 +0200
commitadb85dd473af5c9a72e9da9b7fe013d1b216abc3 (patch)
treeed54d2ce2354cf2b75995d1e1f2bc685436bc4ca /c/configure.ac
parentbsps: Remove AC_CONFIG_SRCDIR() (diff)
downloadrtems-adb85dd473af5c9a72e9da9b7fe013d1b216abc3.tar.bz2
bsps: Move make/custom/* files to bsps
Adjust various build files. Remove automatic generation of the c/src/lib/libbsp/*/acinclude.m4 files from bootstrap script. This patch is a part of the BSP source reorganization. Update #3285.
Diffstat (limited to 'c/configure.ac')
-rw-r--r--c/configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/c/configure.ac b/c/configure.ac
index 92288615ca..f7636239ee 100644
--- a/c/configure.ac
+++ b/c/configure.ac
@@ -5,6 +5,7 @@ AC_PREREQ([2.69])
AC_INIT([rtems-c],[_RTEMS_VERSION],[https://devel.rtems.org/newticket])
AC_CONFIG_SRCDIR([src])
RTEMS_TOP(..)
+with_rtems_source_top=$(cd ${srcdir}/.. && pwd)
RTEMS_SOURCE_TOP
RTEMS_BUILD_TOP
@@ -30,7 +31,7 @@ AS_IF([test x"$enable_rtemsbsp" = x"no"],[
# Check sanity of BSPs in $rtems_bsp
for _rtems_bsp in : $rtems_bsp; do test "x$_rtems_bsp" = x: && continue
- # make sure there is a make/custom file for the bsp
+ # make sure there is a config/*.cfg file for the bsp
_RTEMS_CHECK_CUSTOM_BSP([$_rtems_bsp.cfg],[bsp_cfg])
AS_IF([test -n "$bsp_cfg"],