summaryrefslogtreecommitdiffstats
path: root/c/configure.ac
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2002-10-11 04:31:22 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2002-10-11 04:31:22 +0000
commit2fe08ccb0b89f1bba30cd1e756238c48213433da (patch)
tree2e12c2f34c495abdff060596d9b486b58685067b /c/configure.ac
parent2002-10-11 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-2fe08ccb0b89f1bba30cd1e756238c48213433da.tar.bz2
2002-10-11 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* configure.ac: Apply RTEMS_CONFIGURE_ARGS_QUOTE.
Diffstat (limited to 'c/configure.ac')
-rw-r--r--c/configure.ac28
1 files changed, 2 insertions, 26 deletions
diff --git a/c/configure.ac b/c/configure.ac
index 7768de2cf2..efafec5ee5 100644
--- a/c/configure.ac
+++ b/c/configure.ac
@@ -58,32 +58,8 @@ done
## Adjust paths
_RTEMS_ADJUST_SRCDIR([rtems_bsp_configure],[src])
rtems_bsp_configure="$rtems_bsp_configure/configure"
-
-## Remove --cache-file, --srcdir and --enable-rtemsbsp arguments
-## so they do not pile up
- rtems_bsp_configure_args=
- for ac_arg in $ac_configure_args; do
- if test -n "$ac_prev"; then
- ac_prev=
- continue
- fi
- case "$ac_arg" in
- -cache-file | --cache-file | --cache-fil | --cache-fi \
- | --cache-f | --cache- | --cache | --cach | --cac | --ca | --c)
- ac_prev=cache_file ;;
- -cache-file=* | --cache-file=* | --cache-fil=* | --cache-fi=* \
- | --cache-f=* | --cache-=* | --cache=* | --cach=* | --cac=* | --ca=* | --c=*)
- ;;
- -srcdir | --srcdir | --srcdi | --srcd | --src | --sr)
- ac_prev=srcdir ;;
- -srcdir=* | --srcdir=* | --srcdi=* | --srcd=* | --src=* | --sr=*)
- ;;
- -enable-rtemsbsp=* | --enable-rtemsbsp=*) ;;
- -srcdir=* | --srcdir=* | --srcdi=* | --srcd=* | --src=* | --sr=*)
- ;;
- *) rtems_bsp_configure_args="$rtems_bsp_configure_args $ac_arg" ;;
- esac
- done
+ RTEMS_CONFIGURE_ARGS_QUOTE([rtems_bsp_configure_args],
+ [--enable-rtemsbsp=* | --enable-rtemsbsp=* ) ;;])
rtems_bsp_configure="$rtems_bsp_configure $rtems_bsp_configure_args"
AC_SUBST(rtems_bsp_configure)