summaryrefslogtreecommitdiffstats
path: root/c/configure.ac
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-02-17 13:44:16 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-02-17 13:44:16 +0000
commit1204f225cba8b68baceaca645e338853dc0a8fba (patch)
treea2c88b0a7704b796ad1dadd6bfa5e733fc02671a /c/configure.ac
parent2004-02-17 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-1204f225cba8b68baceaca645e338853dc0a8fba.tar.bz2
2004-02-17 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Cosmetics. * configure.ac: Add support for --disable-rtemsbsp. Cosmetics.
Diffstat (limited to 'c/configure.ac')
-rw-r--r--c/configure.ac15
1 files changed, 10 insertions, 5 deletions
diff --git a/c/configure.ac b/c/configure.ac
index 2a6bf267da..9f02f37098 100644
--- a/c/configure.ac
+++ b/c/configure.ac
@@ -4,7 +4,7 @@
AC_PREREQ(2.59)
AC_INIT([rtems-c],[_RTEMS_VERSION],[rtems-bugs@rtems.com])
-AC_CONFIG_SRCDIR([src])
+AC_CONFIG_SRCDIR([TOOL_TARGETS])
RTEMS_TOP(..)
RTEMS_CANONICAL_TARGET_CPU
@@ -14,12 +14,16 @@ AM_MAINTAINER_MODE
## These options are used within this file.
RTEMS_ENABLE_BARE
-RTEMS_ENABLE_RTEMSBSP(rtems_bsp)
+RTEMS_ENABLE_RTEMSBSP
RTEMS_CHECK_CPU
-AS_IF([test -z "$rtems_bsp"],
- [RTEMS_CHECK_BSPS(rtems_bsp)])
+AS_IF([test x"$enable_rtemsbsp" = x"no"],[
+ rtems_bsp=""
+],[
+ AS_IF([test -z "$enable_rtemsbsp"],
+ [RTEMS_CHECK_BSPS(rtems_bsp)],
+ [rtems_bsp="$enable_rtemsbsp"])
for i in $rtems_bsp; do
@@ -45,11 +49,12 @@ for i in $rtems_bsp; do
AC_MSG_ERROR([unable to find libbsp directory ($bspdir) for $i])
fi
done
+])
#
# Compose the configuration arguments to be passed to c/src/configure
#
- ##
+##
## Partially borrowed from autoconf-2.13
##