summaryrefslogtreecommitdiffstats
path: root/c/build-tools/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>1999-04-19 13:35:24 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>1999-04-19 13:35:24 +0000
commitb6529a34fd5a3b821bfef0cdecea8106a8487ef0 (patch)
tree2d93d2d9b757dbaa87aecd8cf5d8d9c7285bbeb6 /c/build-tools/Makefile.am
parentNew file -- automatically generated. (diff)
downloadrtems-b6529a34fd5a3b821bfef0cdecea8106a8487ef0.tar.bz2
Patch from Ralf Corsepius <corsepiu@faw.uni-ulm.de> to reorganize
the build-tools layout to simplify it. This script reorganizes and simpilfies the build-tools subdirectories. It moves all source-files and scripts to c/build-tools/. This will enable use to use this directory directly to refer to the build-tools instead of copying them around in a "preinstall" step in future. However, RTEMS's autoconf Makefile.ins and *.cfg files are not yet prepared to apply this approach and therefore require additional work.
Diffstat (limited to '')
-rw-r--r--c/build-tools/Makefile.am28
1 files changed, 26 insertions, 2 deletions
diff --git a/c/build-tools/Makefile.am b/c/build-tools/Makefile.am
index e9d608c113..e7c73b923d 100644
--- a/c/build-tools/Makefile.am
+++ b/c/build-tools/Makefile.am
@@ -5,7 +5,31 @@
AUTOMAKE_OPTIONS = foreign
ACLOCAL = @ACLOCAL@ -I $(RTEMS_TOPdir)/aclocal
-SUBDIRS = scripts src
+bin_PROGRAMS=cklength eolstrip packhex unhex
+
+cklength_SOURCES = cklength.c
+eolstrip_SOURCES = eolstrip.c
+packhex_SOURCES = packhex.c
+unhex_SOURCES = unhex.c
+
+bin_SCRIPTS=\
+install-if-change \
+lock-directory \
+unlock-directory \
+rcs-clean
+
+noinst_SCRIPTS = search-id.sh
+
+#
+# HACK: Install to build directory
+#
+install-exec-local: $(bin_PROGRAMS) $(bin_SCRIPTS)
+ if test -n "${RTEMS_BSP}"; then \
+ $(mkinstalldirs) $(PROJECT_ROOT)/${RTEMS_BSP}/build-tools; \
+ $(INSTALL_SCRIPT) $(bin_SCRIPTS) $(PROJECT_ROOT)/${RTEMS_BSP}/build-tools; \
+ $(INSTALL_PROGRAM) $(bin_PROGRAMS) $(PROJECT_ROOT)/${RTEMS_BSP}/build-tools; \
+ fi
+
+preinstall: install-exec-local
-include $(top_srcdir)/../../automake/subdirs.am
include $(top_srcdir)/../../automake/local.am