summaryrefslogtreecommitdiffstats
path: root/c/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-06-12 15:00:15 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-06-12 15:00:15 +0000
commitdf49c60c9671e4a28e636964d744c1f59fb6cb68 (patch)
treeeabd85e189514ad412a35414ba5d483dcda3ef1f /c/Makefile.am
parentPurged as many egcs references as possible. (diff)
downloadrtems-df49c60c9671e4a28e636964d744c1f59fb6cb68.tar.bz2
Merged from 4.5.0-beta3a
Diffstat (limited to 'c/Makefile.am')
-rw-r--r--c/Makefile.am26
1 files changed, 8 insertions, 18 deletions
diff --git a/c/Makefile.am b/c/Makefile.am
index 949c8171d7..172af7c870 100644
--- a/c/Makefile.am
+++ b/c/Makefile.am
@@ -4,17 +4,15 @@
AUTOMAKE_OPTIONS = foreign 1.4
ACLOCAL_AMFLAGS = -I $(RTEMS_TOPdir)/aclocal
+
## NOTE: This Makefile.am is rather fragile to the value of RTEMS_BSP
-## Esp. make clean and make distclean have unwanted side-effects
+## Esp. make clean and make distclean have unwanted side-effects
## if RTEMS_BSP is not properly set up.
RTEMS_BSP = $(RTEMS_BSP_LIST)
-## The '.' in SUBDIRS ensures that local make-targets (xxx-am) will be
+## The '.' in SUBDIRS ensures that local make-targets (xxx-am) will be
## triggered before $(RTEMS_BSP_LIST) subdirectories are made.
-SUBDIRS= \
-make \
-. \
-$(RTEMS_BSP)
+SUBDIRS = make . $(RTEMS_BSP)
## Use @RTEMS_BSP_LIST@ here, using $(RTEMS_BSP_LIST) would trigger
## this rule for invalid BSPs
@@ -30,23 +28,15 @@ $(RTEMS_BSP)
done
## Let all RTEMS' make targets depend on ${RTEMS_BSP}
-all-am: ${RTEMS_BSP}
-debug-am: ${RTEMS_BSP}
-profile-am: ${RTEMS_BSP}
+all-local: ${RTEMS_BSP}
preinstall-am: ${RTEMS_BSP}
depend-am: ${RTEMS_BSP}
## Pull in extra files intro the distribution
-EXTRA_DIST = \
-ACKNOWLEDGEMENTS \
-README.DOS \
-REQUIRES \
-PROBLEMS \
-TESTED \
-README \
-UPDATE_HELP
+EXTRA_DIST = ACKNOWLEDGEMENTS README.DOS REQUIRES PROBLEMS TESTED README \
+ UPDATE_HELP
DIST_SUBDIRS = ${RTEMS_BSP}
## -------------------------------------------------------
include $(top_srcdir)/../automake/subdirs.am
-include $(top_srcdir)/../automake/local.am
+include $(top_srcdir)/../automake/host.am