summaryrefslogtreecommitdiffstats
path: root/c/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>1999-07-26 21:26:44 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>1999-07-26 21:26:44 +0000
commit29e68b75843aa889a15ca8dcfff1cd30fea9e963 (patch)
tree21c6b34565dc7c7e0a7125f0ec71a42b0a3a142c /c/Makefile.am
parentPatch from Ralf Corsepius <corsepiu@faw.uni-ulm.de>: (diff)
downloadrtems-29e68b75843aa889a15ca8dcfff1cd30fea9e963.tar.bz2
Patch from Ralf Corsepius <corsepiu@faw.uni-ulm.de>:
This patch is an addition to "The big-patch" CHANGES: * FIX: c/Makefile.am: bogus comment which changed the behavior of c/Makefile.am removed * FIX: make/custom/ts_i386ex.cfg did not set HAS_NETWORKING correctly (Me thinks it might have been me who added this bogus setting :-). * NEW: removing make targets get, protos, debug_install, profile_install * NEW: replacing clobber with distclean * NEW: Reimplement distclean and clean as reverse depth first make targets (adaptation to automake's behavior) * NEW: removing RCS_CLEAN from make distclean (tools/build/rcs_clean is still in - remove it?) * NEW: "$(RM) Makefile" added to make distclean (adaptation to automake's behavior) * NEW: "$(RM) config.cache config.log" to CLOBBER_ADDITIONS in [lib|exec|tests]/Makefile.in (adaptation to automake's behavior) * NEW: "$(CLEAN_PROTOS)" removed (Not used anywhere) * NEW: binpatch.c moved from i386 bsp tools to tools/build (AFAIS, binpatch is not specific to the pc386 BSP at all) * NEW: AC_EXEEXT added to all configure scripts which contain AC_PROG_CC (Cygwin support) * NEW/Experimental: An experimental implementation of temporary installation tree support in libbsp/i386/pc386/tools/Makefile.am, based on dependency tracking with make, instead of applying INSTALL_CHANGE. REMARK: * This patch is small in size, but changes the behavior of "make clean|distclean|clobber" basically. * This patch does not alter building/compiling RTEMS, ie. there should be no need to rerun all "make all" building tests. KNOWN BUGS: * make RTEMS_BSP="..." distclean in c/ runs "make distclean" in BSPs subdirectories passed through RTEMS_BSP and in "c/." only, but does not descend into other BSP subdirectories previously configured with different settings of make RTEMS_BSP="...". => Workaround: always use the same setting of RTEMS_BSP when working inside the build-tree. * "make [distclean|clean]" do not clean subdirectories, which have been configured at configuration time, but which are not used due to make-time configuration (e.g. macros/networking/rdgb subdirectories). This will problem will vanish by itself when migrating from make-time to configuration-time configuration APPLYING THE PATCH mv c/src/lib/libbsp/i386/pc386/tools/binpatch.c tools/build patch -p1 < rtems-rc-19990709-2.diff autogen
Diffstat (limited to 'c/Makefile.am')
-rw-r--r--c/Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/c/Makefile.am b/c/Makefile.am
index 565f345917..3f62704966 100644
--- a/c/Makefile.am
+++ b/c/Makefile.am
@@ -2,6 +2,10 @@
# $Id$
#
+## NOTE: This Makefile.am is rather fragile to the value of RTEMS_BSP
+## Esp. make clean and make distclean have unwanted side-effects
+## if RTEMS_BSP is not properly set up.
+
AUTOMAKE_OPTIONS = foreign 1.4
ACLOCAL_AMFLAGS = -I $(RTEMS_TOPdir)/aclocal
@@ -12,11 +16,11 @@ SUBDIRS= \
. \
$(RTEMS_BSP)
+
## Use @RTEMS_BSP_LIST@ here, using $(RTEMS_BSP_LIST) would trigger
## this rule for invalid BSPs
@RTEMS_BSP_LIST@: src/configure
@set fnord $(MAKEFLAGS); amf=$$2; \
- # Adjust paths
test -n "${RTEMS_BSP}" && for i in ${RTEMS_BSP}; do \
echo "Configuring RTEMS_BSP=$$i"; \
test -d $$i || mkdir $$i; \
@@ -29,9 +33,7 @@ $(RTEMS_BSP)
## Let all RTEMS' make targets depend on ${RTEMS_BSP}
all-am: ${RTEMS_BSP}
debug-am: ${RTEMS_BSP}
-debug_install-am: ${RTEMS_BSP}
profile-am: ${RTEMS_BSP}
-profile_install-am: ${RTEMS_BSP}
preinstall-am: ${RTEMS_BSP}
depend-am: ${RTEMS_BSP}