summaryrefslogtreecommitdiffstats
path: root/c/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2002-11-02 13:56:52 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2002-11-02 13:56:52 +0000
commitceddf30ff6e09280cb80db8d1adbf0a543571569 (patch)
tree6c1f655a34f438ad46a246715d6e894bae1969ac /c/Makefile.am
parent2002-11-01 Joel Sherrill <joel@OARcorp.com> (diff)
downloadrtems-ceddf30ff6e09280cb80db8d1adbf0a543571569.tar.bz2
2002-11-02 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Use mkinstalldirs instead of mkdir.
Diffstat (limited to 'c/Makefile.am')
-rw-r--r--c/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/c/Makefile.am b/c/Makefile.am
index a06291f0e9..80cbe0f45f 100644
--- a/c/Makefile.am
+++ b/c/Makefile.am
@@ -19,7 +19,7 @@ SUBDIRS = . $(RTEMS_BSP)
@set fnord $(MAKEFLAGS); amf=$$2; \
test -n "${RTEMS_BSP}" && for i in ${RTEMS_BSP}; do \
echo "Configuring RTEMS_BSP=$$i"; \
- test -d $$i || mkdir $$i; \
+ $(mkinstalldirs) $$i; \
( cd $$i && \
CONFIG_SHELL=$(SHELL) RTEMS_BSP=$$i $(rtems_bsp_configure) \
&& $(MAKE) $(AM_MAKEFLAGS) preinstall ) \