summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2018-06-15 08:18:26 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2018-06-15 12:57:32 +0200
commitbac8d934189c02635cca752d36dce1fdad6338b8 (patch)
treee4ce8981b76b63db037a8ba8409852aa98b9b83b /Makefile.am
parentbsp/beatnik: Remove CFLAGS_DEBUG_V (diff)
downloadrtems-bac8d934189c02635cca752d36dce1fdad6338b8.tar.bz2
tools: Remove install-if-change program
The last installed tool in RTEMS repository is the install-if-change script. It is not used to build/install BSPs. This script does the same as the standard "install" program with an additional feature to install variants via the -V command line option. This script is used by the standard Makefile support: c/src/make/host.cfg.in:INSTALL_CHANGE=$(PROJECT_BIN)/install-if-change The INSTALL_CHANGE is used by: c/src/make/host.cfg.in:ifndef INSTALL_CHANGE c/src/make/host.cfg.in:INSTALL_CHANGE=$(PROJECT_BIN)/install-if-change c/src/make/host.cfg.in:INSTALL_VARIANT=$(INSTALL_CHANGE) -V "$(LIB_VARIANT)" Remove the support for variant installation and instead use the standard "install" program. This breaks application Makefiles using the standard Makefile support of RTEMS. Close #3455.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index ad65c1e565..5e9489db28 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -11,7 +11,7 @@ noinst_SCRIPTS = bootstrap
dist-hook:
- @files=`(cd $(srcdir); find cpukit c testsuites tools \
+ @files=`(cd $(srcdir); find cpukit c testsuites \
-name configure.ac -print | sed 's,/configure.ac,,' | sort)`; \
for i in $$files; do \
if test -f $(distdir)/$$i/configure.ac; then : ; \