summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-06-10 20:33:47 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-06-10 20:33:47 +0000
commit0ab65474316231792faec37ec1dbddeaf8645775 (patch)
tree7b215bd6e8886bb1279cbb39522ad81d4af99711
parent110445cba5510f44c0fbd2ff13d7126459c188c6 (diff)
downloadrtems-0ab65474316231792faec37ec1dbddeaf8645775.tar.bz2
Purged as many egcs references as possible.
-rw-r--r--doc/FAQ/FAQ.texi2
-rw-r--r--doc/FAQ/freesw.t2
-rw-r--r--doc/bsp_howto/makefiles.t6
-rw-r--r--doc/rgdb_specs/rgdb_specs.texi2
-rw-r--r--doc/rtems_gdb/rtems_gdb.texi2
-rw-r--r--doc/started/buildc.t4
-rw-r--r--doc/started/nt.t4
-rw-r--r--doc/started/require.t5
-rw-r--r--doc/started/started.texi2
-rw-r--r--doc/started/tversions.texi2
-rw-r--r--doc/started_ada/buildada.t2
-rw-r--r--doc/started_ada/tversions.texi2
12 files changed, 18 insertions, 17 deletions
diff --git a/doc/FAQ/FAQ.texi b/doc/FAQ/FAQ.texi
index bb128237d3..55879e90d3 100644
--- a/doc/FAQ/FAQ.texi
+++ b/doc/FAQ/FAQ.texi
@@ -100,7 +100,7 @@ Common questions have been divided into the following categories.
@c Need to copy the emacs stuff and "trailer stuff" (index, toc) into here
@c
-@c @node Command and Variable Index, Concept Index, Installing EGCS AND NEWLIB, Top
+@c @node Command and Variable Index, Concept Index, Installing GCC AND NEWLIB, Top
@c @unnumbered Command and Variable Index
@c There are currently no Command and Variable Index entries.
diff --git a/doc/FAQ/freesw.t b/doc/FAQ/freesw.t
index d4f095c1cb..ec524b61a6 100644
--- a/doc/FAQ/freesw.t
+++ b/doc/FAQ/freesw.t
@@ -20,7 +20,7 @@ components:
@itemize @bullet
-@item gcc/egcs
+@item gcc
@item binutils
@item gdb
diff --git a/doc/bsp_howto/makefiles.t b/doc/bsp_howto/makefiles.t
index 7019dc01a2..2247d689b4 100644
--- a/doc/bsp_howto/makefiles.t
+++ b/doc/bsp_howto/makefiles.t
@@ -205,9 +205,9 @@ ifeq ($(RTEMS_USE_GCC272),yes)
# BSPs which already had this support.
[...]
else
-# This has rules to link an application using gcc 2.8 or newer or any
-# egcs version. All BSPs should support this. This version is required
-# to support GNAT/RTEMS.
+# This has rules to link an application using gcc 2.8 or newer.
+# All BSPs should support this. This version is required to support
+# GNAT/RTEMS.
define make-exe
$(CC) $(CFLAGS) $(CFLAGS_LD) -o $(basename $@@).exe $(LINK_OBJS)
$(NM) -g -n $(basename $@@).exe > $(basename $@@).num
diff --git a/doc/rgdb_specs/rgdb_specs.texi b/doc/rgdb_specs/rgdb_specs.texi
index 2eb2b8390b..4fe64ae6cb 100644
--- a/doc/rgdb_specs/rgdb_specs.texi
+++ b/doc/rgdb_specs/rgdb_specs.texi
@@ -90,7 +90,7 @@ This is the online version of the RTEMS Remote Debugger Server Specifications.
@c Need to copy the emacs stuff and "trailer stuff" (index, toc) into here
@c
-@c @node Command and Variable Index, Concept Index, Installing EGCS AND NEWLIB, Top
+@c @node Command and Variable Index, Concept Index, Installing GCC AND NEWLIB, Top
@c @unnumbered Command and Variable Index
@c There are currently no Command and Variable Index entries.
diff --git a/doc/rtems_gdb/rtems_gdb.texi b/doc/rtems_gdb/rtems_gdb.texi
index 45ec1547a3..fb94e48cf6 100644
--- a/doc/rtems_gdb/rtems_gdb.texi
+++ b/doc/rtems_gdb/rtems_gdb.texi
@@ -86,7 +86,7 @@ This is the online version of the RTEMS/GDB User's Guide.
@c Need to copy the emacs stuff and "trailer stuff" (index, toc) into here
@c
-@c @node Command and Variable Index, Concept Index, Installing EGCS AND NEWLIB, Top
+@c @node Command and Variable Index, Concept Index, Installing GCC AND NEWLIB, Top
@c @unnumbered Command and Variable Index
@c There are currently no Command and Variable Index entries.
diff --git a/doc/started/buildc.t b/doc/started/buildc.t
index a6e3d330d0..24e4b30ac0 100644
--- a/doc/started/buildc.t
+++ b/doc/started/buildc.t
@@ -381,7 +381,7 @@ as described below:
@item INSTALL_POINT
is the location where you wish the GNU C/C++ cross compilation tools for
RTEMS to be built. It is recommended that the directory chosen to receive
-these tools be named so that it is clear from which egcs distribution it
+these tools be named so that it is clear from which gcc distribution it
was generated and for which target system the tools are to produce code for.
@b{WARNING}: The @code{INSTALL_POINT} should not be a subdirectory
@@ -581,7 +581,7 @@ This can occur for one of the following reasons:
@end itemize
If you are using binutils 2.9.1 or newer with certain versions of
-egcs and gcc, they do not agree on what the name of the newly
+gcc, they do not agree on what the name of the newly
generated cross assembler is. Older binutils called it @code{as.new}
which became @code{as.new.exe} under Windows. This is not a valid
file name, so @code{as.new} is now called @code{as-new}. By using the latest
diff --git a/doc/started/nt.t b/doc/started/nt.t
index f6ad876f68..5a203e6f9f 100644
--- a/doc/started/nt.t
+++ b/doc/started/nt.t
@@ -192,7 +192,7 @@ mkdir /tmp
mkdir /source
mkdir /build
mkdir /build/binutils
-mkdir /build/egcs
+mkdir /build/gcc
@end example
@item The light Bourne shell provided with Cygwin B19 is buggy.
@@ -321,7 +321,7 @@ or Objective-C as Cygwin32 cross-compilers):
@item ln -s ../@value{NEWLIB-UNTAR}/libgloss libgloss
@end itemize
-@item Change to the /build/egcs directory to configure the compiler:
+@item Change to the /build/gcc directory to configure the compiler:
@example
/source/@value{GCC-UNTAR}/configure --verbose --target=m68k-rtems \
diff --git a/doc/started/require.t b/doc/started/require.t
index 6284bfa694..bbd619fca8 100644
--- a/doc/started/require.t
+++ b/doc/started/require.t
@@ -63,9 +63,10 @@ the GNU tools.
@section GNU makeinfo Version Requirements
-In order to build egcs 1.1b or newer, the GNU @code{makeinfo} program
+In order to build egcs 1.1b, gcc 2.9.x, or newer versions, the GNU
+@code{makeinfo} program
installed on your system must be at least version 1.68. The appropriate
-version of @code{makeinfo} is distributed with egcs 1.1b.
+version of @code{makeinfo} is distributed with @code{gcc}.
The following demonstrates how to determine the version of @code{makeinfo}
on your machine:
diff --git a/doc/started/started.texi b/doc/started/started.texi
index 853b646d94..c9afd61228 100644
--- a/doc/started/started.texi
+++ b/doc/started/started.texi
@@ -96,7 +96,7 @@ This is the online version of the Getting Started with RTEMS for C/C++ Users.
@c Need to copy the emacs stuff and "trailer stuff" (index, toc) into here
@c
-@c @node Command and Variable Index, Concept Index, Installing EGCS AND NEWLIB, Top
+@c @node Command and Variable Index, Concept Index, Installing GCC AND NEWLIB, Top
@c @unnumbered Command and Variable Index
@c There are currently no Command and Variable Index entries.
diff --git a/doc/started/tversions.texi b/doc/started/tversions.texi
index c3305c772e..0dbf7fbeac 100644
--- a/doc/started/tversions.texi
+++ b/doc/started/tversions.texi
@@ -18,7 +18,7 @@
@c
-@c GCC/EGCS Version
+@c GCC Version
@c
@set GCC-VERSION gcc 2.95.2
diff --git a/doc/started_ada/buildada.t b/doc/started_ada/buildada.t
index 54ce278b3b..bb6fd3ba65 100644
--- a/doc/started_ada/buildada.t
+++ b/doc/started_ada/buildada.t
@@ -420,7 +420,7 @@ as described below:
@item INSTALL_POINT
is the location where you wish the GNU C/C++ cross compilation tools for
RTEMS to be built. It is recommended that the directory chosen to receive
-these tools be named so that it is clear from which egcs distribution it
+these tools be named so that it is clear from which gcc distribution it
was generated and for which target system the tools are to produce code for.
@b{WARNING}: The @code{INSTALL_POINT} should not be a subdirectory
diff --git a/doc/started_ada/tversions.texi b/doc/started_ada/tversions.texi
index 5e3a05fc45..d3b6ef4b9e 100644
--- a/doc/started_ada/tversions.texi
+++ b/doc/started_ada/tversions.texi
@@ -18,7 +18,7 @@
@c
-@c GCC/EGCS Version
+@c GCC Version
@c
@set GCC-VERSION gcc 2.8.1