summaryrefslogtreecommitdiffstats
path: root/ncurses-5.3/misc/Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'ncurses-5.3/misc/Makefile.in')
-rw-r--r--ncurses-5.3/misc/Makefile.in128
1 files changed, 128 insertions, 0 deletions
diff --git a/ncurses-5.3/misc/Makefile.in b/ncurses-5.3/misc/Makefile.in
new file mode 100644
index 0000000..d60761d
--- /dev/null
+++ b/ncurses-5.3/misc/Makefile.in
@@ -0,0 +1,128 @@
+# $Id$
+##############################################################################
+# Copyright (c) 1998,2000,2001,2002 Free Software Foundation, Inc. #
+# #
+# Permission is hereby granted, free of charge, to any person obtaining a #
+# copy of this software and associated documentation files (the "Software"), #
+# to deal in the Software without restriction, including without limitation #
+# the rights to use, copy, modify, merge, publish, distribute, distribute #
+# with modifications, sublicense, and/or sell copies of the Software, and to #
+# permit persons to whom the Software is furnished to do so, subject to the #
+# following conditions: #
+# #
+# The above copyright notice and this permission notice shall be included in #
+# all copies or substantial portions of the Software. #
+# #
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR #
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, #
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL #
+# THE ABOVE COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER #
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING #
+# FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER #
+# DEALINGS IN THE SOFTWARE. #
+# #
+# Except as contained in this notice, the name(s) of the above copyright #
+# holders shall not be used in advertising or otherwise to promote the sale, #
+# use or other dealings in this Software without prior written #
+# authorization. #
+##############################################################################
+#
+# Author: Thomas E. Dickey <dickey@clark.net> 1996,1997
+#
+# Makefile for ncurses miscellany directory
+#
+# This makes/installs the terminfo database
+#
+# The variable 'srcdir' refers to the source-distribution, and can be set with
+# the configure script by "--srcdir=DIR".
+#
+# The rules are organized to produce the libraries for the configured models,
+# and the programs with the configured default model.
+
+# turn off _all_ suffix rules; we'll generate our own
+.SUFFIXES :
+
+SHELL = /bin/sh
+THIS = Makefile
+
+CF_MFLAGS = @cf_cv_makeflags@
+@SET_MAKE@
+
+DESTDIR = @DESTDIR@
+top_srcdir = @top_srcdir@
+srcdir = @srcdir@
+prefix = @prefix@
+exec_prefix = @exec_prefix@
+bindir = @bindir@
+libdir = @libdir@
+datadir = @datadir@
+
+CC = @CC@
+HOSTCC = @BUILD_CC@
+
+tabsetdir = $(datadir)/tabset
+ticdir = @TERMINFO@
+source = @TERMINFO_SRC@
+
+INSTALL = @INSTALL@
+INSTALL_DATA = @INSTALL_DATA@
+
+################################################################################
+all :
+
+depend :
+
+sources :
+
+install : install.data
+
+install.data : $(DESTDIR)$(libdir) \
+ $(DESTDIR)$(ticdir) \
+ $(DESTDIR)$(tabsetdir)
+ DESTDIR=${DESTDIR} \
+ prefix=${prefix} \
+ exec_prefix=${exec_prefix} \
+ bindir=${bindir} \
+ top_srcdir=${top_srcdir} \
+ srcdir=${srcdir} \
+ datadir=${datadir} \
+ ticdir=${ticdir} \
+ source=${source} \
+ THIS_CC="$(CC)" \
+ THAT_CC="$(HOSTCC)" \
+ sh ./run_tic.sh
+ @cd $(srcdir)/tabset && \
+ sh -c 'for i in * ; do \
+ if test -f $$i ; then \
+ echo installing $$i; \
+ $(INSTALL_DATA) $$i $(DESTDIR)$(tabsetdir)/$$i; \
+ fi; done'
+
+$(DESTDIR)$(libdir) \
+$(DESTDIR)$(tabsetdir) \
+$(DESTDIR)$(ticdir) :
+ sh $(srcdir)/../mkinstalldirs $@
+
+uninstall : uninstall.data
+
+uninstall.data :
+ -cd $(DESTDIR)$(ticdir) && rm -rf *
+ -cd $(DESTDIR)$(tabsetdir) && rm -rf *
+
+tags :
+
+@MAKE_UPPER_TAGS@TAGS :
+
+mostlyclean :
+ -rm -f core tags TAGS *~ *.bak *.ln *.atac trace
+
+clean :: mostlyclean
+
+distclean : clean
+ -rm -f Makefile run_tic.sh
+
+realclean : distclean
+
+###############################################################################
+# The remainder of this file is automatically generated during configuration
+###############################################################################