summaryrefslogtreecommitdiffstats
path: root/RTEMS_Makefiles
diff options
context:
space:
mode:
authorEric Norum <WENorum@lbl.gov>2001-04-25 20:06:48 +0000
committerEric Norum <WENorum@lbl.gov>2001-04-25 20:06:48 +0000
commitd35892bf0b018f285d1f60dd28480c343de357ef (patch)
tree9e8dc186f1e116a8773567dbe81808c293dc9fa4 /RTEMS_Makefiles
parentUseful add-on libraries (diff)
downloadrtems-addon-packages-d35892bf0b018f285d1f60dd28480c343de357ef.tar.bz2
Useful add-on libraries
Diffstat (limited to 'RTEMS_Makefiles')
-rw-r--r--RTEMS_Makefiles/Makefile.ncurses28
-rw-r--r--RTEMS_Makefiles/Makefile.readline10
2 files changed, 38 insertions, 0 deletions
diff --git a/RTEMS_Makefiles/Makefile.ncurses b/RTEMS_Makefiles/Makefile.ncurses
new file mode 100644
index 0000000..ae2a3f0
--- /dev/null
+++ b/RTEMS_Makefiles/Makefile.ncurses
@@ -0,0 +1,28 @@
+#
+# Declare supported terminal types.
+# This value can be augmented/overridden by the site-configuration file
+#
+TERMINALS=xterm,vt100,linux
+
+include ../RTEMS_Makefiles/Makefile.common
+
+#
+# The following will work only if you have the latest ncurses version
+# of infocmp installed before trying to build for an RTEMS target.
+# The cf_cv_type_of_bool hack works around a bug when configuring
+# for a cross-target.
+#
+all:
+ cf_cv_type_of_bool=char CXX="$(CC)" ./configure \
+ --host=`uname -m`-$(RTEMS_HOST) \
+ --prefix=$(exec_prefix) \
+ --libdir=$(exec_prefix)/$(RTEMS_BSP)/lib \
+ --includedir=$(exec_prefix)/$(RTEMS_BSP)/lib/include \
+ --without-ada \
+ --without-progs \
+ --without-cxx-binding \
+ --disable-sigwinch \
+ --disable-database \
+ --with-fallbacks="$(TERMINALS)"
+ make "HOSTCC=gcc" "HOSTCCFLAGS=-I. -I../include" HOSTLDFLAGS=""
+ make install
diff --git a/RTEMS_Makefiles/Makefile.readline b/RTEMS_Makefiles/Makefile.readline
new file mode 100644
index 0000000..f13372f
--- /dev/null
+++ b/RTEMS_Makefiles/Makefile.readline
@@ -0,0 +1,10 @@
+include ../RTEMS_Makefiles/Makefile.common
+
+all:
+ ./configure \
+ --host=`uname -m`-$(RTEMS_HOST) \
+ --prefix=$(exec_prefix) \
+ --libdir=$(exec_prefix)/$(RTEMS_BSP)/lib \
+ --includedir=$(exec_prefix)/$(RTEMS_BSP)/lib/include
+ make
+ make install