summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2011-04-08 17:33:18 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2011-04-08 17:33:18 +0000
commitf6bb837f7810457e0399a12610705143909f7040 (patch)
tree1382453c4297b08ebc5f2ed820c9d49d3fb4d6ea
parent2011-04-08 Joel Sherrill <joel.sherrill@oarcorp.com> (diff)
downloadrtems-addon-packages-f6bb837f7810457e0399a12610705143909f7040.tar.bz2
2011-04-08 Joel Sherrill <joel.sherrill@oarcorp.com>
* RTEMS_Makefiles/Makefile.gsl: New file.
-rw-r--r--ChangeLog4
-rw-r--r--RTEMS_Makefiles/Makefile.gsl19
2 files changed, 23 insertions, 0 deletions
diff --git a/ChangeLog b/ChangeLog
index 96b4f78..b88cd6a 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,5 +1,9 @@
2011-04-08 Joel Sherrill <joel.sherrill@oarcorp.com>
+ * RTEMS_Makefiles/Makefile.gsl: New file.
+
+2011-04-08 Joel Sherrill <joel.sherrill@oarcorp.com>
+
* RTEMS_Makefiles/Makefile.readline-4.3,
readline-4.3/CHANGELOG-ReadLine, readline-4.3/CHANGES,
readline-4.3/COPYING, readline-4.3/ChangeLog, readline-4.3/INSTALL,
diff --git a/RTEMS_Makefiles/Makefile.gsl b/RTEMS_Makefiles/Makefile.gsl
new file mode 100644
index 0000000..1a995b6
--- /dev/null
+++ b/RTEMS_Makefiles/Makefile.gsl
@@ -0,0 +1,19 @@
+#
+# Declare supported terminal types.
+# This value can be augmented/overridden by the site-configuration file
+#
+include ../RTEMS_Makefiles/Makefile.common
+
+#
+# The following will work only if you have the latest ncurses version
+# of infocmp installed before trying to build for an RTEMS target.
+# The cf_cv_type_of_bool hack works around a bug when configuring
+# for a cross-target.
+#
+all:
+ ./configure --host=$(RTEMS_CPU)-rtems$(RTEMS_API) \
+ --prefix=$(exec_prefix) \
+ --includedir=$(exec_prefix)/lib/include \
+ --disable-shared
+ make
+ make install