summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2011-04-08 15:40:51 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2011-04-08 15:40:51 +0000
commitc1893955f00258dfd206477f72f83b9c62a08494 (patch)
treeccdf9d8e76243bb10000ff07de114030bce3da50
parent2011-04-08 Joel Sherrill <joel.sherrill@oarcorp.com> (diff)
downloadrtems-addon-packages-c1893955f00258dfd206477f72f83b9c62a08494.tar.bz2
2011-04-08 Joel Sherrill <joel.sherrill@oarcorp.com>
* ncurses-5.9/ncurses/tty/lib_twait.c: Need conditional on __rtems__.
-rw-r--r--ChangeLog4
-rw-r--r--ncurses-5.9/ncurses/tty/lib_twait.c3
2 files changed, 7 insertions, 0 deletions
diff --git a/ChangeLog b/ChangeLog
index 4276977..9c4b653 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,5 +1,9 @@
2011-04-08 Joel Sherrill <joel.sherrill@oarcorp.com>
+ * ncurses-5.9/ncurses/tty/lib_twait.c: Need conditional on __rtems__.
+
+2011-04-08 Joel Sherrill <joel.sherrill@oarcorp.com>
+
* bit: Update to ncurses-5.9.
* ncurses-5.9/ANNOUNCE, ncurses-5.9/AUTHORS, ncurses-5.9/INSTALL,
ncurses-5.9/MANIFEST, ncurses-5.9/Makefile.in,
diff --git a/ncurses-5.9/ncurses/tty/lib_twait.c b/ncurses-5.9/ncurses/tty/lib_twait.c
index 557ca81..ea2d7a3 100644
--- a/ncurses-5.9/ncurses/tty/lib_twait.c
+++ b/ncurses-5.9/ncurses/tty/lib_twait.c
@@ -68,6 +68,9 @@
#ifdef __MINGW32__
# include <sys/time.h>
#endif
+#ifdef __rtems__
+# include <sys/time.h>
+#endif
#undef CUR
MODULE_ID("$Id$")