summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Norum <WENorum@lbl.gov>2002-12-18 16:35:47 +0000
committerEric Norum <WENorum@lbl.gov>2002-12-18 16:35:47 +0000
commit7ada560a8d6a47be43827c2adea1ee85372a5fc9 (patch)
tree7d1ba3c52f919961d81fd59d7f040503ac124aa8
parentI don't know how this ever worked -- somehow the host CPU was getting merged (diff)
downloadrtems-addon-packages-7ada560a8d6a47be43827c2adea1ee85372a5fc9.tar.bz2
Update ncurses add-on package
-rw-r--r--RTEMS_Makefiles/Makefile.ncurses-5.330
1 files changed, 30 insertions, 0 deletions
diff --git a/RTEMS_Makefiles/Makefile.ncurses-5.3 b/RTEMS_Makefiles/Makefile.ncurses-5.3
new file mode 100644
index 0000000..75715d1
--- /dev/null
+++ b/RTEMS_Makefiles/Makefile.ncurses-5.3
@@ -0,0 +1,30 @@
+#
+# Declare supported terminal types.
+# This value can be augmented/overridden by the site-configuration file
+#
+TERMINALS=xterm,vt100,linux,ansi
+
+include ../RTEMS_Makefiles/Makefile.common
+
+#
+# The following will work only if you have the latest ncurses version
+# of infocmp installed before trying to build for an RTEMS target.
+# The cf_cv_type_of_bool hack works around a bug when configuring
+# for a cross-target.
+ #cf_cv_type_of_bool=char CXX="$(CC)" ./configure \
+#
+all:
+ CXX="$(CC)" ./configure \
+ --host=$(RTEMS_CPU)-rtems \
+ --prefix=$(exec_prefix) \
+ --libdir=$(exec_prefix)/$(RTEMS_BSP)/lib \
+ --includedir=$(exec_prefix)/$(RTEMS_BSP)/lib/include \
+ --without-ada \
+ --without-progs \
+ --without-cxx-binding \
+ --with-bool="unsigned char" \
+ --disable-sigwinch \
+ --disable-database \
+ --with-fallbacks="$(TERMINALS)"
+ make "HOSTCC=gcc" "HOSTCCFLAGS=-I. -I../include" HOSTLDFLAGS=""
+ make install