summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2006-06-24 14:22:34 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2006-06-24 14:22:34 +0000
commit6738a8207b62894679aa4f624ebf1d762d08104e (patch)
tree9fd223251075ff5e2ab337275b2b672241af4cae
parentReverse junk changes. (diff)
downloadrtems-addon-packages-6738a8207b62894679aa4f624ebf1d762d08104e.tar.bz2
Use GCC to link not LD so the CPU_CFLAGS are easier to access correctly.
-rw-r--r--rtemsNfs/src/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/rtemsNfs/src/Makefile b/rtemsNfs/src/Makefile
index aee298b..8797fcf 100644
--- a/rtemsNfs/src/Makefile
+++ b/rtemsNfs/src/Makefile
@@ -63,7 +63,7 @@ CFLAGS +=
# CFLAGS_DEBUG_V += -qrtems_debug
#
-LDFLAGS += $(CPU_CFLAGS)
+LDFLAGS +=
#
# Add your list of files to delete here. The config files
@@ -80,13 +80,14 @@ RTEMS_SITE_INSTALLDIR = $(PROJECT_RELEASE)
endif
%nfs.obj: %nfs.o %nfs.modini.o
- $(LD) $(LDFLAGS) -r -o $@ $^ -L../proto/$(ARCH) -lnfsprot
+ $(CC_FOR_TARGET) -Xlinker -r -nodefaultlibs $(CPU_CFLAGS) \
+ -o $@ $^ -L../proto/$(ARCH) -lnfsprot
%rpcio.obj: %rpcio.o %sock_mbuf.o %xdr_mbuf.o %rpcio.modini.o
- $(LD) $(LDFLAGS) -r -o $@ $^
+ $(CC_FOR_TARGET) -Xlinker -r -nodefaultlibs $(CPU_CFLAGS) -o $@ $^
%dirutils.obj: %dirutils.o
- $(LD) $(LDFLAGS) -r -o $@ $^
+ $(CC_FOR_TARGET) -Xlinker -r -nodefaultlibs $(CPU_CFLAGS) -o $@ $^
$(LIB): $(OBJS)
$(make-library)