summaryrefslogtreecommitdiffstats
path: root/bsd_eth_drivers/if_em/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2009-02-19 19:55:40 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2009-02-19 19:55:40 +0000
commit89376b7141edb6f927fb940c27391cda6e67c785 (patch)
tree57dd01fd9328b879289493ba848ae5c34c607b91 /bsd_eth_drivers/if_em/Makefile.am
downloadlibbsdport-89376b7141edb6f927fb940c27391cda6e67c785.tar.bz2
Initial import.initial
Diffstat (limited to 'bsd_eth_drivers/if_em/Makefile.am')
-rw-r--r--bsd_eth_drivers/if_em/Makefile.am39
1 files changed, 39 insertions, 0 deletions
diff --git a/bsd_eth_drivers/if_em/Makefile.am b/bsd_eth_drivers/if_em/Makefile.am
new file mode 100644
index 0000000..1a6a12f
--- /dev/null
+++ b/bsd_eth_drivers/if_em/Makefile.am
@@ -0,0 +1,39 @@
+# $Id$
+AUTOMAKE_OPTIONS=foreign
+
+include $(top_srcdir)/rtems-pre.am
+
+libif_em_a_SOURCES = if_em.c
+libif_em_a_SOURCES += e1000_80003es2lan.c e1000_82540.c e1000_82541.c
+libif_em_a_SOURCES += e1000_82543.c e1000_82571.c e1000_82575.c
+libif_em_a_SOURCES += e1000_api.c e1000_mac.c e1000_manage.c
+libif_em_a_SOURCES += e1000_nvm.c e1000_phy.c
+
+libif_em_a_SOURCES += e1000_80003es2lan.h e1000_82541.h e1000_82543.h
+libif_em_a_SOURCES += e1000_82571.h e1000_82575.h e1000_api.h
+libif_em_a_SOURCES += e1000_defines.h e1000_hw.h e1000_ich8lan.h
+libif_em_a_SOURCES += e1000_mac.h e1000_manage.h e1000_nvm.h
+libif_em_a_SOURCES += e1000_osdep.h e1000_phy.h e1000_regs.h if_em.h
+
+EXTRA_libif_em_a_SOURCES = e1000_82542.c e1000_ich8lan.c
+
+CPPFLAGS_82542_SUPPORT_NO = -DNO_82542_SUPPORT
+CPPFLAGS_ICH8LAN_SUPPORT_NO = -DNO_ICH8LAN_SUPPORT
+
+O_PIECES_82542_SUPPORT_YES = e1000_82542.$(OBJEXT)
+O_PIECES_ICH8LAN_SUPPORT_YES = e1000_ich8lan.$(OBJEXT)
+
+libif_em_a_LIBADD =
+libif_em_a_LIBADD += $(O_PIECES_82542_SUPPORT_$(ENBL_82542_SUPPORT))
+libif_em_a_LIBADD += $(O_PIECES_ICH8LAN_SUPPORT_$(ENBL_ICH8LAN_SUPPORT))
+
+libif_em_a_DEPENDENCIES = $(libif_em_a_LIBADD)
+
+lib_LIBRARIES = libif_em.a
+
+AM_CPPFLAGS += -I$(srcdir)
+AM_CPPFLAGS += -I$(srcdir)/../libbsdport -I../libbsdport -I../libbsdport/dummyheaders
+AM_CPPFLAGS += $(CPPFLAGS_82542_SUPPORT_$(ENBL_82542_SUPPORT))
+AM_CPPFLAGS += $(CPPFLAGS_ICH8LAN_SUPPORT_$(ENBL_ICH8LAN_SUPPORT))
+
+include $(top_srcdir)/rtems.am