summaryrefslogtreecommitdiff
path: root/contrib/repo-conf/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/repo-conf/configure.ac')
-rw-r--r--contrib/repo-conf/configure.ac17
1 files changed, 11 insertions, 6 deletions
diff --git a/contrib/repo-conf/configure.ac b/contrib/repo-conf/configure.ac
index eda31c2952..6aeb02976e 100644
--- a/contrib/repo-conf/configure.ac
+++ b/contrib/repo-conf/configure.ac
@@ -2,7 +2,7 @@
# Process this file with autoconf to produce a configure script.
AC_PREREQ(2.61)
-AC_INIT([rtems-]_RTEMS_API[-repo-conf],[0.15],[http://www.rtems.org/bugzilla],
+AC_INIT([rtems-]_RTEMS_API[-repo-conf],[0.16],[http://www.rtems.org/bugzilla],
[rtems-]_RTEMS_API[-repo-conf])
RTEMS_VERSIONING
@@ -19,25 +19,29 @@ AC_ARG_ENABLE(osname,AS_HELP_STRING(
case $osname in
fedora-9* | fedora-10* | fedora-11* )
os_name="Fedora"
- os_subdir="fedora/"
+ os_subdir="fedora"
+ os_vers=`echo $osname| sed -e 's,^.*-,,'`
yum_verdir="\$\$releasever"
apt_verdir="\$\$(VERSION)"
;;
centos-5* | redhat-el5* | fedora-7* | fedora-8* )
os_name="CentOS"
- os_subdir="centos/"
+ os_subdir="centos"
+ os_vers=`echo $osname| sed -e 's,^.*-,,'`
yum_verdir="5"
apt_verdir="5"
;;
centos-4* | redhat-el4* | fedora-5* | fedora-6* )
os_name="CentOS"
- os_subdir="centos/"
+ os_subdir="centos"
+ os_vers=`echo $osname| sed -e 's,^.*-,,'`
yum_verdir="4"
apt_verdir="4"
;;
suse-*)
os_name="openSUSE"
- os_subdir="suse/"
+ os_subdir="suse"
+ os_vers=`echo $osname| sed -e 's,^.*-,,'`
yum_verdir="\$\$releasever"
apt_verdir="\$\$(VERSION)"
;;
@@ -45,10 +49,11 @@ suse-*)
AC_MSG_ERROR([Unsupported OS])
esac
+AC_SUBST([OS_NAME],[$os_name])
AC_SUBST([OS_SUBDIR],[$os_subdir])
+AC_SUBST([OS_VERS],[$os_vers])
AC_SUBST([YUM_VERDIR],[$yum_verdir])
AC_SUBST([APT_VERDIR],[$apt_verdir])
-AC_SUBST([OS_NAME],[$os_name])
AC_CONFIG_FILES([Makefile])
AC_OUTPUT