summaryrefslogtreecommitdiff
path: root/contrib/crossrpms/autotools/rtems-4.8-autoconf.spec
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/crossrpms/autotools/rtems-4.8-autoconf.spec')
-rw-r--r--contrib/crossrpms/autotools/rtems-4.8-autoconf.spec38
1 files changed, 30 insertions, 8 deletions
diff --git a/contrib/crossrpms/autotools/rtems-4.8-autoconf.spec b/contrib/crossrpms/autotools/rtems-4.8-autoconf.spec
index 1d713c213e..c5572198f3 100644
--- a/contrib/crossrpms/autotools/rtems-4.8-autoconf.spec
+++ b/contrib/crossrpms/autotools/rtems-4.8-autoconf.spec
@@ -3,24 +3,44 @@
# http://www.rtems.org/bugzilla
#
-%define _prefix /opt/rtems-4.8
-%define _infodir %{_prefix}/info
-%define _mandir %{_prefix}/man
+%define _prefix /opt/rtems-4.8
+%define _exec_prefix %{_prefix}
+%define _bindir %{_exec_prefix}/bin
+%define _sbindir %{_exec_prefix}/sbin
+%define _libexecdir %{_exec_prefix}/libexec
+%define _datarootdir %{_prefix}/share
+%define _datadir %{_datarootdir}
+%define _sysconfdir %{_prefix}/etc
+%define _sharedstatedir %{_prefix}/com
+%define _localstatedir %{_prefix}/var
+%define _includedir %{_prefix}/include
+%define _libdir %{_exec_prefix}/%{_lib}
+%define _mandir %{_datarootdir}/man
+%define _infodir %{_datarootdir}/info
+%define _localedir %{_datarootdir}/locale
%ifos cygwin cygwin32 mingw mingw32
%define _exeext .exe
+%define debug_package %{nil}
+%define _libdir %{_exec_prefix}/lib
%else
%define _exeext %{nil}
%endif
%ifos cygwin cygwin32
%define optflags -O3 -pipe -march=i486 -funroll-loops
-%define _libdir %{_exec_prefix}/lib
-%define debug_package %{nil}
+%endif
+
+%ifos mingw mingw32
+%if %{defined _mingw32_cflags}
+%define optflags %{_mingw32_cflags}
+%else
+%define optflags -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions --param=ssp-buffer-size=4 -mms-bitfields
+%endif
%endif
%if "%{_build}" != "%{_host}"
-%define _host_rpmprefix rtems-4.8-%{_host}-
+%define _host_rpmprefix %{_host}-
%else
%define _host_rpmprefix %{nil}
%endif
@@ -36,7 +56,7 @@ License: GPL
URL: http://www.gnu.org/software/autoconf
Group: Development/Tools
Version: %{rpmvers}
-Release: 6%{?dist}
+Release: 7%{?dist}
Summary: Tool for automatically generating GNU style Makefile.in's
Obsoletes: rtems-4.8-autoconf-rtems < %{version}-%{release}
@@ -52,7 +72,8 @@ Requires: m4 gawk
Requires(post): /sbin/install-info
Requires(preun): /sbin/install-info
-Source0: ftp://ftp.gnu.org/gnu/autoconf/autoconf-%{srcvers}.tar.bz2
+Source0: ftp://ftp.gnu.org/gnu/autoconf/autoconf-%{srcvers}.tar.bz2
+
%description
GNU's Autoconf is a tool for configuring source code and Makefiles.
@@ -69,6 +90,7 @@ their use.
%prep
%setup -q -n autoconf-%{srcvers}
+%{?PATCH0:%patch0 -p1}
# Work around rpm inserting bogus perl-module deps
cat << \EOF > %{name}-prov